Graylog container bind local port to a port other than 9000?

Hello all,

I have been attempting to bind a different local port for graylog 4.0 WebUI as it would conflict with another containers. Is it possible to use a different local port binding for this container? I have been using the graylog 4.0 document and did not see any mention whether or not this was possible. Based on my understanding the below options in the docker compose file should be sufficient to do what I want but it is not working. Also to add to this the remote host running the container has its firewall disabled and with the conflicting container stopped graylog will work just fine. Please let me know if there is anything I missed.

    # Graylog web interface and REST API
      - 7555:7555

Thank you

Not sure about Docker, but on the *Nix version I also had to open port 9000 in the OS firewall. If I wanted 7555, I would need to do the same. Thank you, Zach.

Any of the config options in server.conf can be used as env vars by prefixing them with GRAYLOG_. That said, GRAYLOG_HTTP_BIND_ADDRESS is probably what you’re looking for, or better yet, why not just change your port matting to something like 7555:9000. You wouldn’t even have to change the bind address.

Good afternoon dinckinsonzach and aaronsachs,

Thank you for the responses, I do have the OS firewall disabled so all port traffic should be allowed (Something I do plan changing on in the future). I will however use GRAYLOG_HTTP_BIND_ADDRESS I remember seeing somewhere that only GRAYLOG_HTTP_EXTERNAL_URI was required so that may have been part of my issue. I will try again and review the documents if needed. Once I have this fixed I will respond here again. If there are any other questions please let me know.

Thank you,

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.