Graylog behind a proxy and src parameter

I have Graylog behind NAT and proxy
It listens on 127.0.0.1 and requests are routed to this IP:port from public IP
It’s pretty much the same as described in Web interface — Graylog 4.0.0 documentation

The problem is that inside of index page of Graylog absolute path is used, like

<link rel="shortcut icon" href="http://127.0.0.1:9000/assets/favicon.png">
<script src="http://127.0.0.1:9000/config.js">
<script src="http://127.0.0.1:9000/assets/vendor.594b2a39cb22b445205e.js">

Browser obviously fails to load resources from 127.0.0.1
What’s the reason of using absolute path and how to correct it?

Hello,

Not sure if you seen this post. Looks like it has some information that might help.

Hope that helps

Thank you, unfortunately I don’t have Nginx, it’s just port forwarding
I’ve created Graylog behind a proxy and src parameter · Issue #10632 · Graylog2/graylog2-server · GitHub to try to address this issue

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.