Graylog 3.0 Sidecar isnt working

Hi everyone, I hope someone can help me. I have installed new graylog version and trying to make sidecars work but still not successful. Legacy sidecars functioning without issues.
Firewall is not blocking any ports whatsoever.

Error I’m having
Failed to connect to backoff(async(tcp://x.x.x.x:5000)): dial tcp x.x.x.x:5000: connectex: No connection could be made because the target machine actively refused it

what have you done exactly with what version and what have you configured and what is the exact error you see where?

I have installed Graylog 3.0. Trying to import logs onto Graylog via graylog_sidecar_installer_1.0.0-1.exe on Windows Server 2016 with NXLog. I can see my host, Collector is running.
However, logs are not coming through. the part of my nxlog configuration is the following

Module om_tcp Host Port 12201 OutputType GELF_TCP # These fields are needed for Graylog $gl2_source_collector = '${sidecar.nodeId}'; $collector_node_id = '${sidecar.nodeName}'; The input is ![Capture|205x140](upload://w30R0ncZFK8xAkEvP7GaZvCuzpj.png) Errors, I can see directly on my windows server (C:\Program Files (x86)\nxlog\data). \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ 2019-03-08 10:47:10 INFO reconnecting in 128 seconds 2019-03-08 10:47:10 ERROR couldn't connect to tcp socket on; No connection could be made because the target machine actively refused it. \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ ![tempsnip|690x210](upload://tBfPnyu01ERdptMKw58jQKXWEf.png) I have tried with winlogbeat and with nxlog, its the same error. I confirm that firewall is not blocking any ports.

Thank you for your time

did you created the input in Graylog where you want to send messages into?

Yes, of course

This is my sidecar.yml conf

did you open the local firewall port?

That the connection is refused ist mostly a sign that something is blocking the connection. You need to check by command line, via telnet and other tools if you can connect to that port and if not you need to find what is blocking. Sherlock, the game has started, solve the riddle.

Thanks Jan, I was able to resolve an issue. I made a mistake in nxlog configuration.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.