Graylog 2.3 cluster issue


(Evgen787) #1

Hi, all.

Perhaps the error is not new, but it can not be solved.

We have 2 nodes(master and slave). MongoDB cluster (3 nodes).

Slave node does not work…
WARN [NodePingThread] Did not find meta info of this node. Re-registering.

When i stopped master and run slave, i can enter to gui and see slave node, and after that, i`m start master. After several seconds - Did not find meta info of this node… (slave node logs)

graylog-server 2.3.2 (Deb 8)

What could be the problem?


(Jochen) #2

Impossible to tell if you don’t provide substantial information such as a description of your network setup, the configuration of your Graylog nodes, and the logs of your Graylog nodes.


(Evgen787) #3

Hi!
Ok,I’m upload conf of nodes later.
So,when we create cluster, all works fine.


(Jan Doberstein) #4

did you checked the solution in the linked thread?


(Evgen787) #5

When I looked first time date, I did not notice that it was not true, now I checked the ntpq -c peers, and i see problems.
Now, everything is working.
Thanks.

I have one small question, nodes in System/Nodes have IP, not the names.
Where is set node names?


(Jan Doberstein) #6

if you refer to the System > Nodes page, the names shown is the name that the system think it has. That is returned to the java process request the hostname.


(Evgen787) #7

hostname is correct on nodes. Hmm, why java used IP…


(Jan Doberstein) #8

use the following java function to get the hostname

https://docs.oracle.com/javase/8/docs/api/java/net/InetAddress.html#getLocalHost--


(Evgen787) #9

$ java -jar testhostname.jar
Hostname: valid_hostname

Function above worked on nodes.


(system) #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.