Expired Certificate


Just hit this error today … is there a certificate or server issue perhaps? BTW, this is when trying to run apt update on Ubuntu,

Err:24 https://packages.graylog2.org/repo/debian stable Release
  Certificate verification failed: The certificate is NOT trusted. The certificate chain uses expired certificate.  Could not handshake: Error in the certificate verification. [IP: 443]
Reading package lists... Done
E: The repository 'https://packages.graylog2.org/repo/debian stable Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.


1 Like

I am seeing the same thing, trying do run “sudo apt-get update” on Ubuntu 18.04. I installed using the directions in the 3.2 documentation.

1 Like

Yep, exactly! Worked fine until today … you too?

Yep, it was working, I built my graylog server a few days ago with no problems.

OK, same issue here - just started happening. Let’s hope it’s fixed before too long :smile:


Can we merge my ticket with this one? Just tried to do a non Docker install and got this as well. Thought it was me.

Sure, NP - seems they have an issue on their repository / server side.

I had the same issue with the OVA install. If you want a quick fix, just remove the https and replace with http.
Not ideal but gets around this issue until it is resolved. Adjust the below for the branch you want to use:

sudo nano /etc/apt/sources.list.d/graylog.list
deb http://packages.graylog2.org/repo/debian/ stable 3.2
deb http://packages.graylog2.org/repo/debian/ stable 3.3

You can also leave the https versions in there if you want to keep an eye on when the certs are fixed on the repository you are landing on.


Yep, that’s a workaround - up for now at least. Thanks!

1 Like

Right everyone is facing same issue while installing

I just checked sometime back and seems it has been fixed.

1 Like

Working here now also - thanks!

sorry for the problems - actually our monitoring did not alerted us on this as the certificate itself was still valid.

But the CA certificate had expired.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.