Error when searching with API

Hello everyone!

I have a (to me at least) strange problem with the API. Here’s the actual API call:

curl -k -u username:password ""

Now, one of my hosts in my three hosts cluster is returning 1 message - as expected. The other two just give me this:

must not be empty (path = RelativeSearchResource.searchRelativeChunked.arg6, invalidValue = null)

It’s the exact same call, just the IP changed…

The one that is working is not the master, if that’s at all relevant.

Thank you for any insights and any help at all! (I’m on version 3.3.8)

Oh, and a bonus question: is this API endpoint the right one for searching? It works (when it does…) as I need it to work, but in the API browser it’s prepended with “Legacy…”. Is there a better option?

Just a little update: I’m on version 4.0 now and now two of my three hosts are working… :expressionless:
That’s obviously better, but since I want to make my API calls through the load balancer (for TLS etc.) that’s still not good enough…

After restarting the Graylog service on the last non-working node, it’s working on that one also. Case closed… :slight_smile:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.