Error when run graylog.jar

Hello, it’s my first post and my english is not god, so forgive me!
My problem is when i try run the graylog.jar.
When a try i’ve this error:

Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.NoClassDefFoundError: org/bouncycastle/jce/provider/BouncyCastleProvider
	at java.lang.Class.getDeclaredMethods0(Native Method)
	at java.lang.Class.privateGetDeclaredMethods(Class.java:2729)
	at java.lang.Class.privateGetMethodRecursive(Class.java:3076)
	at java.lang.Class.getMethod0(Class.java:3046)
	at java.lang.Class.getMethod(Class.java:1812)
	at sun.launcher.LauncherHelper.validateMainClass(LauncherHelper.java:544)
	at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:526)
Caused by: java.lang.ClassNotFoundException: org.bouncycastle.jce.provider.BouncyCastleProvider
	at java.net.URLClassLoader.findClass(URLClassLoader.java:382)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:418)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
	... 7 more

Someone can help me?!

Plese post more information: graylog version, operating system, installation steps, in which situation error occured and so on…

Version: 3.3.2
OS: Manjaro
For installation i’m only clone the project end build.

Plese post your java version:

java -version  
javac -version  

java -version

openjdk version "1.8.0_265"
OpenJDK Runtime Environment Corretto-8.265.01.1 (build 1.8.0_265-b01)
OpenJDK 64-Bit Server VM Corretto-8.265.01.1 (build 25.265-b01, mixed mode)

javac -version

javac 1.8.0_265

And do you have problem with compilation, or compilation worked fine, but graylog did not start. Which method do you use to start graylog? Systemd service?

You can still use precompiled graylog package from AUR:

My compilation worked fine, my problem occurs when i run the graylog.jar
I’ll try this precompiled

This project don’t solve my problem
I think this problem is with the dependency bouncycastle, but i’ve try with many versions, and anyone works

Problem solved, i’ve been used the wrong graylog.jar
:slight_smile: