Email config not enabled. helm / rancher /kubernetes

Hi … I’m hoping someone here can help me with a graylog kubernetes/rancher install using the helm chart for graylog.

I’ve been battling with this for weeks with slow progress… But I’m slowly getting there !!

I have a graylog cluster up and working(events arriving ) However I cannot get the email setup to work.

Here is the yaml answer file I am using in rancher


externalUri: “”





      name: gelf1

      port: 12222


      name: gelf2

      port: 12223


    loadBalancerIP: ""

    type: LoadBalancer




      name: syslog

      port: 5140


    loadBalancerIP: ""

    type: LoadBalancer


rootPassword: secret

rootTimezone: Europe/Paris


type: LoadBalancer

transportEmail.enabled: true

transportEmail.fromEmail: graylog@here

transportEmail.hostname: “”

transportEmail.port: 25

transportEmail.subjectPrefix: graylog

transportEmail.useAuth: false

transportEmail.useTls: false

When I try to test/create a new alert it gives me "email config not enabled… I can see the helm answers in the api and don’t get any install warnings. Cant find any errors in the pod logs.

I tried adding the email config to the conf: helm answer, and I can see it in the pod graylog.conf file (doubled) but still no joy (and no way to delete duplicate lines)

Email transport

transport_email_enabled = false

transport_email_hostname =

transport_email_port = 2587

transport_email_use_auth = true

transport_email_use_tls = true

transport_email_use_ssl = false

transport_email_auth_username =

transport_email_auth_password =

transport_email_subject_prefix = [graylog]

transport_email_from_email =

transport_email_web_interface_url =

content_packs_dir = /usr/share/graylog/data/contentpacks

content_packs_auto_load = grok-patterns.json

proxied_requests_thread_pool_size = 32

transport_email_enabled = true

transport_email_hostname =

transport_email_port = 25

transport_email_use_auth = false

transport_email_subject_prefix = [graylog]

transport_email_from_email = graylog@here

transport_email_use_tls = false

Nothing in any of the rancher logs so i’m scratching my head on this …

Could someone share how they got it working ?



This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.