Elasticsearch backup error

Hello Community, after restoring Elasticsearch backup my graylag is showing me this error: -

While retrieving data for this widget, the following error(s) occurred:

  • Elasticsearch exception [type=index_not_found_exception, reason=no such index ].

anyone who can help me please.

Did you restore into the same cluster that the backup was taken from? What was the reason you had to do a restore? How old was the backup? Do the indexes show under system>indices?

Hello @Joel_Duffield thanks for the replay bro.
I solved; the issue was I forget to recalculate the index after restoring.

however, I have another issue bro which is after restoring the indexes. I can only see the default indexes in graylog not the other ones.

for example, I can see graylog-2, graylog_0 indexes, but I can’t see window_2 indexes.

here is my graylag indices.

Also, at the server I can see the windows indexes in my Elasticsearch.

Thanks always for the replay bro I really appreciate it.

Are you just rolling back data in a cluster, or are you restoring data into a new cluster (to migrate data from one cluster to another)?

I’m restoring data into new graylag server bro.
So far, I restored the backup I can see all the indexes, and I recalculated them, I can see logs inside the default indexes like graylog_0,1,2, but I can’t see the logs of the other index that I manually created before such as windows_0,2 indexes.

As you can see my indexes are stored and I recalculated them

I can see the logs of the default indexes but I can’t see the logs of this index

is there is something I am missing bro?

solved the issue was I didn’t restore Mongodb database.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.