Disable searches in all streams when I open Graylog

Hi All,

We have structured Graylog in a way that each service has its own stream. When I open the graylog, it searches in all the streams by default. This causes a heavy operation which is time consuming and user has to wait for its completion before he can fire his own search. This brings an unnecessary delay and a heavy operation execution. Can somebody please guide me to disable this?
One option I see is that I can make changes in JS to select a stream by default. But If it can be handled via configuration, that will be better.

Hello and Welcome,
It would help if we had more details about your environment.

This could give you a better Idea.

Hi @gsmith , I did not understand what kind of details are you looking for.
We are using Graylog in our production environment to manage logs of multiple services.
We have created a different stream for each service (~50).
Please let know what other details are required

From what you told me this is all I know about your environment.

If you read the link above, specially the part

Details you should always include

This would be very helpfull in helping you. I kinda get the sum of what your talking about. I just set mine as shown below. Its a drop down, in the stream that was created. See the red box.

I’m running Graylog 4.0.5, ES 7.10 and MongDB 4.2 All on one server. It has 1 TB storage, 10 GB RAM, and 10 CPU’s. It handles 30 million files a day = about 30 GB per day. No problems

I hope this helps.

Thanks @gsmith. Understood what details you were asking. I tried “Set as startpage” but it was disabled. I read about it and got to know that it doesn’t work for the admin account. I used another user with admin role and I am able to set the startpage.
This has helped in reducing initial load time.

Thanks !!!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.