Datetime isn't proper in Email alerts


#1

Hello!

I have configured Graylog 2.4.3. To send Email notifications i have installed and configured postfix SMTP server. There is config of /etc/graylog-server/server.conf

# Email transport
transport_email_enabled = true
transport_email_hostname = localhost
transport_email_port = 25
transport_email_use_auth = false
transport_email_use_tls = false
transport_email_use_ssl = false
transport_email_auth_username = 
transport_email_auth_password = 
transport_email_subject_prefix = [graylog]
transport_email_from_email = root@graylog-sec

There is timezone config:

# Default is UTC
root_timezone = Europe/Moscow

Also in the page http://graylog.sec:9000/system/authentication/config timezone is Moscow too.

Configured E-Mail Body in “Editing alert configuration” window is:

Datetime: ${check_result.triggeredAt}

${if backlog}
${foreach backlog message}
${message.message}
${end}${end}

But when alerts are being recieved, the time in alert (Datetime: ${check_result.triggeredAt}) is UTC anyway. But should be Europe/Moscow (UTC+3).

What did i miss?

Thanks in advance!


(Jochen) #2

The timestamps used in the email alert notifications is always UTC. It’s not configurable.

The root_timezone configuration settings only affects the timezone used for the administrator in the web interface.


#3

Maybe it could be configured in some kind of addon’s config? At least it should be configured in the place where alert is taking the timezone)
Thanks anyway!


(Jochen) #4

Sure, you could write a plugin with a modified email alarm callback which uses different configuration settings.


(system) #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.