Couldn't point deflector to a new index org.graylog2.indexer.ElasticsearchException elasticsearch couldn't point deflector to a new index

Hello we are running Graylog 3.1.3 on our system, and we are not able to rotate its indices also we are not able to close and delete the active indices, and we are facing this issue for all indices.

Tried resetting the read-only flag on all indices as suggested by graylog community but still its not working.

curl -X PUT “localhost:9200/_all/_settings?pretty” -H ‘Content-Type: application/json’ -d’
“index.blocks.read_only_allow_delete”: null

If your Elasticsearch set itself to read only that means you likely ran short on disk space… was that the issue? Do you have enough disk space to clear the high watermark and not have it happen again?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.