Clean Install of Graylog 5 - Connection Refused in Browser

I just performed a clean install on Ubuntu 22.04 using the Ubuntu Installation instructions.

Pre-reqs installed - check
MongoDB installed and running - check
Elasticsearch installed and running - check
Graylog installed, server.conf updated, and service running - check

Go to login to http://IP_ADDRESS:9000 = Connection Refused

Compared the server.conf to another graylog sever I have access to that is working and the only differences are the http_bind_address, the password_secret and the sha256 password.

What could I be missing?

Hello && welcome

Did you check firewall/permissions/ Selinux/etc…
If you not useing HTTPS and using the IP Address for your node, then something like this

[root@graylog graylog_user]# cat /etc/graylog/server/server.conf  | egrep -v "^\s*(#|$)"
is_master = true
node_id_file = /etc/graylog/server/node-id
password_secret = epOqmLi7r7CdZXXFxyHAAsdgmCfyHhSKlKXjMQG9ojc0bn22
root_password_sha2 = 5e884898da28047151d0e56f8dc6292773603d0d6aabbdd62a11ef721d1542d8
root_email = ""
root_timezone = America/Chicago
bin_dir = /usr/share/graylog-server/bin
data_dir = /var/lib/graylog-server
plugin_dir = /usr/share/graylog-server/plugin
http_bind_address = IP _ADDRESS:9000

EDIT: Have you seenthis section?

Welp… sometimes it’s the easy things you tend to blow right past. Apparently the enable command to make sure mongo starts at system boot didn’t take and mongo wasn’t running after reboot. Fixed that and BAM! In. Thanks for those who replied and provided possible solutions.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.