Cant upgrade from 5.0.8-1 to 5.1 on Ubuntu

I cant upgrade from 5.0.8-1 to 5.1 on Ubuntu. I tried upgrading after performing all apt updates, verifying prerequisites (5.0.x and 5.1.x are the same) , restarting the server and then stopping the graylog service. No option to upgrade shows with apt update when following docs at Prerequisites

I’m on 22.04LTS and the docs for sudo apt-cache policy graylog return:

  Installed: (none)
  Candidate: (none)
  Version table:

But if i run apt-cache policy graylog-server command instead i get

  Installed: 5.0.8-1
  Candidate: 5.0.8-1
  Version table:
 *** 5.0.8-1 500
        500 stable/5.0 amd64 Packages
        100 /var/lib/dpkg/status
     5.0.7-1 500

apt update returns “All packages are up to date.”.

It’s not pinned. The following returns blank: apt-mark showhold | grep graylog-server

Which steps did you follow?

Try the steps here: Operating System Packages

1 Like

Thanks for the tip. I successfully performed the upgrade from the link in your post. The following was missing from the upgrade docs:

sudo dpkg -i graylog-5.1-repository_latest.deb
sudo apt-get update

The steps I originally followed that do not work are here under “Upgrading Graylog > Upgrading Graylog in Ubuntu” with version 5.1 selected :|_____5

Thank you for the feedback. I will ask someone to take a look and correct those docs. Sorry for the inconvenience.