Can't login to fresh installation


(Sebastiaan Speck) #1

I am trying to log in using admin admin.

I ran echo -n admin | shasum -a 256 with the result of:
8c6976e5b5410415bde908bd4dee15dfb167a9c873fc4bb8a81f6f2ab448a918 -

This is how my server.conf file looks for the password:
root_password_sha2 = 8c6976e5b5410415bde908bd4dee15dfb167a9c873fc4bb8a81f6f2ab448a918


(Tess) #2

I’ve verified your config with:

$ read PASS
admin
$ echo -n ${PASS} | sha256sum
8c6976e5b5410415bde908bd4dee15dfb167a9c873fc4bb8a81f6f2ab448a918   -

So at least that checks out.

Your config line also looks good. So the final question would be: did you restart Graylog after making the change? :wink:

Also, do you get any specific error messages on the login screen? And what does the Graylog logfile tell you? Refer to /var/log/graylog-server/server.log


(Jan Doberstein) #3

remove - the space and - from the line of the password.

Use this command to generate:

echo -n "Enter Password: " && head -1 </dev/stdin | tr -d '\n' | sha256sum | cut -d" " -f1

(Sebastiaan Speck) #4

I get several exceptions/errors:

  • java Exception: java.net.BindException: Address already in use
  • Error that shutsdowns Graylog:
org.graylog2.bootstrap.ServerBootstrap - Graylog startup failed. Exiting. Exception was:
java.lang.IllegalStateException: Expected to be healthy after starting. The following services are not running: {FAILED=[JerseyService [FAILED]]}
	at com.google.common.util.concurrent.ServiceManager$ServiceManagerState.checkHealthy(ServiceManager.java:740) ~[graylog.jar:?]
	at com.google.common.util.concurrent.ServiceManager$ServiceManagerState.awaitHealthy(ServiceManager.java:553) ~[graylog.jar:?]
	at com.google.common.util.concurrent.ServiceManager.awaitHealthy(ServiceManager.java:312) ~[graylog.jar:?]
	at org.graylog2.bootstrap.ServerBootstrap.startCommand(ServerBootstrap.java:149) [graylog.jar:?]
	at org.graylog2.bootstrap.CmdLineTool.run(CmdLineTool.java:209) [graylog.jar:?]
	at org.graylog2.bootstrap.Main.main(Main.java:44) [graylog.jar:?]

But after that error, if I run ./graylogctl status I get graylog-server not running, but still I can go to the login-page in Chrome and try to login


(Tess) #5

Well, that’s something entirely different from “the username and password aren’t working”! :slight_smile:

, if I run ./graylogctl status

Could it be you’re using the VM image provided by Graylog?


(Sebastiaan Speck) #6

I followed this tut: http://docs.graylog.org/en/2.4/pages/installation/manual_setup.html


(Tess) #7

Ahhh, then I guess that graylogctl is not part of the standard RPM and DEB packages, but is included with the TGZ. Makes sense, because the RPM and DEB would rely on systemctl or service, whereas the TGZ is a generic installer to be used on Whatever Linux™.

So back to basics… Why did you originally ask about the username and password in the config file? Right now your question seems more focused on having conflicting Graylog instances on one box. Now’s the time for Linux-101 and troubleshooting; I hope you have some experience with that :slight_smile: Graylog is not different from any other Linux-stack application when it comes to troubleshooting processes, ports and listeners.


(Jan Doberstein) #8

I personal would recommend using the OS Packages for your distribution for first time users.


(Sebastiaan Speck) #9

The main problem is that I want to run it on MacOS. So therefore I used the TGZ


(Tess) #10

Makes sense… In that case you’ll still need to do the Linux-101 troubleshooting to determine what’s going wrong :slight_smile: Keep track of your processes and ports…


(system) #11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.