Can't increase heap size on AWS AMI


(Chris Foster) #1

Hello all, Sorry to sound like a noob with regards this subject. I can’t seem to increase the heap size for my graylog Instance. I’ve been through pages of documents regarding the subject but yet to find one that helps.

I can’t seem to find where the default value is set. I have changed/added the following lines to the elasticsearch.yml
ES_MIN_MEM: 4g
ES_MAX_MEM: 4g

I have also checked the jvm.options settings and changed them to the following
-Xms4g
-Xmx4g

any and all help would be appreciated.

Regards

Deadribs


(Jochen) #2

If you’re using one of the virtual appliances based on the Graylog Omnibus package, you have to use the graylog-ctl utility to configure it.

See also: http://docs.graylog.org/en/2.4/pages/configuration/graylog_ctl.html#advanced-settings


(Chris Foster) #3

Thank you @jochen for the timely response.

Saved me a headache.


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.