Cannot import extractor - no error in logs or web ui; error in ExtractorsStore.js

Hey Graylog Community,

Long-time lurker, first-time poster. And, I hope this isn’t too much of a noob question, but I’m having a devil of a time getting my graylog instance to import any content pack/extractor that I’ve found in the new marketplace. Graylog’s web interface doesn’t present any error when I attempt to import, and the logs for graylog, itself, also show no errors at the time of import.

However, when looking at the developer console in Chrome, I do see that, as soon as I hit ‘import,’ that Chrome throws an error relating to ExtractorsStore.js. In particular, Chrome says:

> Uncaught TypeError: Cannot read properties of undefined (reading 'forEach')
>     at f.import (ExtractorsStore.js:229:18)
>     at o.n (vendor.3b152b3d9c1d8273aa7e.js:2:949206)
>     at o.emit (vendor.3b152b3d9c1d8273aa7e.js:2:49834)
>     at Function.trigger (vendor.3b152b3d9c1d8273aa7e.js:2:950087)
>     at vendor.3b152b3d9c1d8273aa7e.js:2:950192
>     at N.<computed> (task.js:61:7)
>     at S (task.js:35:5)
>     at MessagePort.O (task.js:46:3)
> import               @ ExtractorsStore.js:229
> n                       @ vendor.3b152b3d9c1d8273aa7e.js:2
> o.emit               @ vendor.3b152b3d9c1d8273aa7e.js:2
> trigger               @ vendor.3b152b3d9c1d8273aa7e.js:2
> (anonymous)    @ vendor.3b152b3d9c1d8273aa7e.js:2
> N.<computed> @ task.js:61
> S                      @ task.js:35
> O                      @ task.js:46

I am running graylog on an Arch Linode server that uses an nginx reverse proxy to expose the web interface (graylog only listens on localhost). The instance has been rock solid since install except for this one issue. I’ve got an input going that’s successfully ingested ~2 million messages, but now I’m tripping getting usable data out of them.

I’ve tried to import the extractor from Chrome beta and Firefox stable on Arch, Chrome stable on Android 13, and Safari stable and Chrome stable on whatever the latest version of macOS is.

Any insight from my fellow users?



Hello @ian-foss

Graylog version do you have? and what’s the name content pack/extractor.

To be honest this may have something to do with content pack from the Market.
Have you tried to posting where you got this content pack? perhaps the creator could identify the issue.

Have you imported content packs before, if so were there any issues?

Uncaught TypeError: Cannot read properties of undefined (reading 'forEach')

  • The function was passed undefined on a variable.
  • Variable somehow got unset or overwritten with the value undefined.
  • You made your computer angry

With that being said, chances are it might be the content pack.

Hi there, @gsmith. I’m running the latest version of Graylog.

And, turns out that you were exactly right and it just so happens that the same problem was presenting itself with all the content packs. Weird.

Either way, I’ve found some that work and am squared away.

1 Like

If you could post what your workaround is, it may help future searchers with similar issue… :smiley:

Sure thing.

For those who encounter a similar issue, I solved mine by using a different content pack that didn’t throw the error. In particular, for nginx, I’m using this one, which works well for me since I dump all my logs to syslog anyway.

Instead of trying to import others, I did some ‘harder work,’ by creating my own IP extractors from pre-installed Grok patterns, since this was the biggest thing I was immediately after. And, by harder work, I mean three to four extra clicks.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.