Can no longer edit extractors


(Jason Haar) #1

I’m running graylog-2.3.2 and some time recently have started to notice that editing extractors is failing. eg if I choose an existing extractor and click “Edit”, the “loading…” thingy appears, but it never actually loads. Listing the extractors works and so does adding a new one - but I cannot edit existing ones

I get the same issue under Firefox and Chrome - so it must be a server issue

Any ideas? Thanks

Jason


#2

i noticed this as well about a year ago, but switched over to using pipelines as well, because i heard it may be phased out eventually. mine did eventually load and i was able to grab the extractors. perhaps a restart of graylog/mongodb wouldn’t hurt


(Jan Doberstein) #3

Hej @jason

are you still having the problem? Did you refreshed your Browsers cache? Did you notice any errors in the Graylog server.log?


(Jason Haar) #4

No - still not working. Really weird: today I successfully exported the
extractors (for our UDP syslog Input channel), deleted each one using the
"delete" button (I had 80-ish extractors - a bit of an effort ;-), then
imported the extractors back in - no problem. But I cannot edit any one of
them individually…

I’ve tried it with Firefox and Chrome - so it’s not a caching issue, and
the only time “extractor” shows up in graylog logfile is from a couple of
weeks ago - nothing from right now as my attempt to edit an extractor fails


(Jan Doberstein) #5

hej @jason

could you please fill a bug report about that then.

thank you


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.