Blank page when try to access web interface (Solved)

Hello, I’ve been stuck in a problem for more than 1 week.

I have been trying to install graylog on a ubuntu 18.04 virtual machine and I followed the instructions found on the official graylog Docs.

Everything seems to be working, but when I try to access the web interface ( I get a blank page.

I oppened the following ports : 9200,80,12900,9000

file server.conf:

is_master = true
node_id_file = /etc/graylog/server/node-id
password_secret = xxxxx
root_password_sha2 = xxxxx
bin_dir = /usr/share/graylog-server/bin
data_dir = /var/lib/graylog-server
plugin_dir = /usr/share/graylog-server/plugin

http_bind_address =
rest_listen_uri =
web_listen_uri =
elasticsearch_network_host =
rotation_strategy = count
elasticsearch_max_docs_per_index = 20000000
elasticsearch_max_number_of_indices = 20
retention_strategy = delete
elasticsearch_shards = 4
elasticsearch_replicas = 0
elasticsearch_index_prefix = graylog
allow_leading_wildcard_searches = false
allow_highlighting = false
elasticsearch_analyzer = standard
output_batch_size = 500
output_flush_interval = 1
output_fault_count_threshold = 5
output_fault_penalty_seconds = 30
processbuffer_processors = 5
outputbuffer_processors = 3
processor_wait_strategy = blocking
ring_size = 65536

inputbuffer_ring_size = 65536
inputbuffer_processors = 2
inputbuffer_wait_strategy = blocking
message_journal_enabled = true
message_journal_dir = /var/lib/graylog-server/journal
lb_recognition_period_seconds = 3
mongodb_uri = mongodb://localhost/graylog
mongodb_max_connections = 1000
mongodb_threads_allowed_to_block_multiplier = 5
proxied_requests_thread_pool_size = 32

graylog logs:

2021-01-04T12:31:18.978Z INFO [Periodicals] Starting [] periodical in [3600s], polling every [28800s].
2021-01-04T12:31:18.979Z INFO [Periodicals] Starting [] periodical in [120s], polling every [86400s].
2021-01-04T12:31:18.979Z INFO [Periodicals] Starting [org.graylog.plugins.collector.periodical.PurgeExpiredCollectorsThread] periodical in [0s], polling every [3600s].
2021-01-04T12:31:43.647Z INFO [NetworkListener] Started listener bound to []
2021-01-04T12:31:43.649Z INFO [HttpServer] [HttpServer] Started.
2021-01-04T12:31:43.649Z INFO [JerseyService] Started REST API at <>
2021-01-04T12:31:43.651Z INFO [ServiceManagerListener] Services are healthy
2021-01-04T12:31:43.652Z INFO [InputSetupService] Triggering launching persisted inputs, node transitioned from Uninitialized [LB:DEAD] to Running [LB:ALIVE]
2021-01-04T12:31:43.653Z INFO [ServerBootstrap] Services started, startup times in ms: {InputSetupService [RUNNING]=11, OutputSetupService [RUNNING]=43, JobSchedulerService [RUNNING]=43, EtagService [RUNNING]=44, UrlWhitelistService [RUNNING]=48, BufferSynchronizerService [RUNNING]=50, JournalReader [RUNNING]=51, GracefulShutdownService [RUNNING]=68, ConfigurationEtagService [RUNNING]=78, KafkaJournal [RUNNING]=83, MongoDBProcessingStatusRecorderService [RUNNING]=133, StreamCacheService [RUNNING]=156, LookupTableService [RUNNING]=163, PeriodicalsService [RUNNING]=172, JerseyService [RUNNING]=24837}
2021-01-04T12:31:43.658Z INFO [ServerBootstrap] Graylog server up and running.

I’ve been trying to use similar topic to fix this issue, but no success so far.

:wave: Hi @fabiano,

Given what you’re seeing, it sounds like you’re missing http_enable_cors = true. Try adding that to your Graylog config and restart.

Hello @aaronsachs, thanks for your answer. I added what you suggested, but I still get the same problem, blank page.

Are you seeing anything in your browser’s console?

@aaronsachs This is what my console shows

That looks like the API isn’t running. But looking over your config again, the rest_listen_uri and web_listen_uri are old parameters, and the elasticsearch_network_host isn’t part of any recent configs that I’ve seen. What version are you trying to set up?

@aaronsachs I got it fixed. the problem was the line , http_publish_uri, it was commentend.
It was fixed by adding http_publish_uri = http://MypublicIP:9000/.

Thank you for your attention.

1 Like

Hey I am also having this same issue. My server is an Azure VM and I am not able to access the web interface. I can view a blank white page.

Hello @ijazm123 I got it fixed by adding

publish_uri = http://mypublicip:9000/

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.