Auto update a Dashboard on Graylog 3.2

Can anyone point me into the right direction to get a Dashboard update every x seconds when starting?

It works just fine when you press on the play button next to [Not updating]
We want the dashboards to start with the [ update every 1 second ] on.


  • Table Message widget
  • Source based on a stream (do not think that this matters)
  • Chrome and Internet Explorer tested

I don’t think [ save ] and [ save as ] buttons apply to this setting.

Things I tried:

  • dashboard_widget_default_cache_time = 1s
  • Tried searching for a time setting in the user profiel. There is something about background browser technique. I tried setting that to true
  • 3.1 documentation talked about widget settings but I couldn’t find that on 3.2

I even tried to hack the mongodb views document, but apparently the db.views values have some relations to other documents with ObjectID, because saving the exact same information caused the dashboards not to load at all anymore …

Kind regards from

Unfortunately nobody seems to know how to do this.

We found a hack that seems to work for our needs:

  • cd /usr/share/graylog-server
  • mkdir tmp
  • cp graylog.jar org_graylog.jar
  • cd tmp
  • cp …/graylog.jar .
  • jar xvf graylog.jar
  • vi web-interface/assets/app.8f8a24a8d49ce905d0ae.js
    Search for:
function(e){var r=e.size;

Put the following javascript in between the ‘{’ and var r=e.size();

function (e){ if(document.getElementsByClassName("dropdown-menu").item(4).innerText.indexOf("1 Second") > -1){document.getElementsByClassName("dropdown-menu").item(4).querySelector("ul li a").click();} }, 1000);        var r=e.size();
  • jar -uvf graylog.jar web-interface/assets/app.8f8a24a8d49ce905d0ae.js; yes | cp graylog.jar …/. ; service graylog-server restart; tail -f /var/log/graylog-server/server.log
adding: web-interface/assets/app.8f8a24a8d49ce905d0ae.js(in = 6014931) (out= 1569425)(deflated 73%)

he @mdotedot

I’m not sure what is wrong on the in Graylog available option?


and more better with the “full screen” you can have auto update of multiple tabs in auto update:


Thanks for the reply.

I’m not sure if I’m understanding your reply correctly.

When we start a dashboard it starts on ‘Not Updating’ <- we want to start in one of the refresh options.

If you are implying that editing a dashboard with that setting and saving it : that didn’t produce the dashboard with auto-refresh and you still need to select one of the refresh options.

Ow … wait … You are right. The options that I need are in the FULL SCREEN section.

Thank you very much!! That is what we are looking for!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.