Apache SSO Configuration does not work


(ptrk) #1

Hi everybody,

does anybody here have simple, working sso config for apache here?
I’m stuck.

I am able to pass the Apache Auth. I see Remote-User Header, but then i see only the standard Graylog Login page.

I appreciate any help!


(Jochen) #2

A typical mistake is that the IP address of the proxy server (Apache httpd in your case) is missing in the trusted_proxies setting in Graylog.


(ptrk) #3

Thank you for your help already.
I made this setting, but it’s not working either.

Here is the main snip of the apache config file

    <Proxy *>
        Order deny,allow
        Allow from all
    </Proxy>

    <Location />
       AuthType Kerberos
       AuthName "DOMAIN LOGIN (HTTPS)"
       KrbMethodNegotiate off
       KrbAuthoritative on
       KrbVerifyKDC off
       KrbAuthRealms DOMAINNAME
       require valid-user

        RequestHeader set X-Graylog-Server-URL "https://192.168.1.1:10443/api/"
        Header set X-Forwarded-User %{REMOTE_USER}s
        ProxyPass http://127.0.0.1:9000/
        ProxyPassReverse http://127.0.0.1:9000/
    </Location>

(Jochen) #4

(system) #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.