Added plugins not visible in UI or /var/graylog-server/server.log

#1

I’m adding plugins like sso, and slack to my graylog3.0 AMI ubuntu install, and adding the plugins to the default plugins dir but unable to view them (after gray-server restart). I’ve also attempted to restart the ec2 instance, but no avail.

Thoughts?

======plugin dir ls =======
root@logs:/usr/share/graylog-server/plugin# ll
-rw-r–r-- 1 root root 633 Mar 31 17:21 graylog2-plugin-input-httpmonitor-1.0.5.jar
-rw-r–r-- 1 root root 623 Mar 31 17:31 graylog-plugin-auth-sso-3.0.0.jar
-rw-r–r-- 1 root root 18049238 Feb 11 07:56 graylog-plugin-aws-3.0.0.jar
-rw-r–r-- 1 root root 2742366 Feb 11 07:56 graylog-plugin-collector-3.0.0.jar
-rw-r–r-- 1 root root 633 Mar 31 17:22 graylog-plugin-input-httpmonitor-1.0.5.jar
-rw-r–r-- 1 root root 143625 Feb 11 07:56 graylog-plugin-integrations-3.0.0.jar
-rw-r–r-- 1 root root 620 Mar 31 18:58 graylog-plugin-slack-3.1.0.jar
-rw-r–r-- 1 root root 4251902 Feb 11 07:56 graylog-plugin-threatintel-3.0.0.jar

====server.conf=======
proxied_requests_thread_pool_size = 32
allow_highlighting = true
is_master = true
node_id_file = /etc/graylog/server/node-id
password_secret = [omit]
root_password_sha2 = [omit]
root_timezone = US/Central
bin_dir = /usr/share/graylog-server/bin
data_dir = /var/lib/graylog-server
plugin_dir = /usr/share/graylog-server/plugin
http_bind_address = 0.0.0.0:9000
rotation_strategy = count
elasticsearch_max_docs_per_index = 20000000
elasticsearch_max_number_of_indices = 20
retention_strategy = delete
elasticsearch_shards = 4
elasticsearch_replicas = 0
elasticsearch_index_prefix = graylog
allow_leading_wildcard_searches = false
elasticsearch_analyzer = standard
output_batch_size = 500
output_flush_interval = 1
output_fault_count_threshold = 5
output_fault_penalty_seconds = 30
processbuffer_processors = 5
outputbuffer_processors = 3
processor_wait_strategy = blocking
ring_size = 65536
inputbuffer_ring_size = 65536
inputbuffer_processors = 2
inputbuffer_wait_strategy = blocking
message_journal_enabled = true
message_journal_dir = /var/lib/graylog-server/journal
lb_recognition_period_seconds = 3
mongodb_uri = mongodb://localhost/graylog
mongodb_max_connections = 1000
mongodb_threads_allowed_to_block_multiplier = 5
proxied_requests_thread_pool_size = 32
allow_highlighting = true

====journal -xe========

● graylog-server.service - Graylog server
Loaded: loaded (/usr/lib/systemd/system/graylog-server.service; enabled; vendor preset: enabled)
Drop-In: /etc/systemd/system/graylog-server.service.d
└─10-after_services.conf
Active: active (running) since Mon 2019-04-01 09:59:20 CDT; 23min ago
Docs: http://docs.graylog.org/
Main PID: 15875 (graylog-server)
Tasks: 179 (limit: 4915)
CGroup: /system.slice/graylog-server.service
├─15875 /bin/sh /usr/share/graylog-server/bin/graylog-server
└─15880 /usr/bin/java -Xms1g -Xmx1g -XX:NewRatio=1 -server -XX:+ResizeTLAB -XX:+UseConcMarkSweepGC -XX:+CMSConcurrentMTEnabled -XX:+CMSClassUnloadingEnabled -XX:+UseParNewGC -XX:-OmitStackTraceInFastThrow -jar -Dlog4j.configurationFile=file:///etc/graylog/server/log4j2.xml -Djava.library.path=/usr/share/graylog-server/lib/sigar -Dgraylog2.installation_source=deb /usr/share/graylog-server/graylog.jar server -f /etc/graylog/server/server.conf -np

Apr 01 09:59:20 logs systemd[1]: Started Graylog server.

======pertinent logs ======

2019-04-01T10:35:21.655-05:00 INFO [CmdLineTool] Loaded plugin: AWS plugins 3.0.0 [org.graylog.aws.AWSPlugin]
2019-04-01T10:35:21.658-05:00 INFO [CmdLineTool] Loaded plugin: Integrations 3.0.0 [org.graylog.integrations.IntegrationsPlugin]
2019-04-01T10:35:21.658-05:00 INFO [CmdLineTool] Loaded plugin: Collector 3.0.0 [org.graylog.plugins.collector.CollectorPlugin]
2019-04-01T10:35:21.659-05:00 INFO [CmdLineTool] Loaded plugin: Threat Intelligence Plugin 3.0.0 [org.graylog.plugins.threatintel.ThreatIntelPlugin]
2019-04-01T10:35:21.934-05:00 INFO [CmdLineTool] Running with JVM arguments: -Xms1g -Xmx1g -XX:NewRatio=1 -XX:+ResizeTLAB -XX:+UseConcMarkSweepGC -XX:+CMSConcurrentMTEnabled -XX:+CMSClassUnloadingEnabled -XX:+UseParNewGC -XX:-OmitStack
TraceInFastThrow -Dlog4j.configurationFile=file:///etc/graylog/server/log4j2.xml -Djava.library.path=/usr/share/graylog-server/lib/sigar -Dgraylog2.installation_source=deb
2019-04-01T10:35:22.121-05:00 INFO [Version] HV000001: Hibernate Validator 5.1.3.Final

0 Likes

#2

nvm, figured it out. The files weren’t actually saved as jar files, tl;dr don’t use curl -O :slight_smile:

0 Likes

(system) closed #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

0 Likes