Why my Looup Table is not appearing in Decorator Dropdown


(Blason) #1

Hi Team,

I created a CSV lookup and and latest tested which worked fine. However when I am applying in Decorator its not shwoing my created Look Up table. Those just shows the default ones

Can someone please help?


(Jan Doberstein) #2

What Version of Graylog did you use? I can’t reproduce that on the 2.4.6 release.


(Blason) #3

It is 2.4.6 and dang I tried everything but the lookup table created I am not able to see in Decorator.


(Blason) #4

These is for example

L2

L3

L4


(Jan Doberstein) #5

can you scroll down in the drop down?


(Blason) #6

Nope that’s all the entries currently present there.
in face I replicated the same setup elsewhere and its a same issue.


(Jan Doberstein) #7

I can’t reproduce that with GL 2.4.6 - all self created Lookup Tables are presented:

grafik


(Blason) #8

This is strange and then why this is not working with me? I tried that twice on different machines/setups and that failed.

Is it because the CSV has 1 million records? well while testing it works perfectly only thing its not reflecting to attach.


(Kay Roepke) #9

The CSV lookup table will load all the entries into memory, so you might run into Java heap/garbage collection issues.
You could take a look at the System / Nodes page to see whether some nodes have very high memory usage and if that is the case slowly increase the heap size of the processes, see http://docs.graylog.org/en/2.4/pages/faq.html?highlight=heap#raise-the-java-heap for instructions.

Don’t drastically increase the heap of Graylog Server, as that can negatively impact performance.

Also if you use the CSV file adapter, usually you don’t need use an additional cache.


(Blason) #10

OK - Let me see that by deleting cache.