When attempting to edit Dashboard item error "can't convert undefined to object"

Before you post: Your responses to these questions will help the community help you. Please complete this template if you’re asking a support question.
Don’t forget to select tags to help index your topic!

1. Describe your incident:
When attempting to edit an existing dashboard in Graylog 4.3.9 I receive the Something went wrong page with can’t convert undefined to object in the error field

2. Describe your environment:

  • OS Information: Ubuntu 18.04 running as VMware VM with 6 CPU and 32GB memory 500GB storage.

  • Package Version:
    Graylog version 4.3.9 - Elasticsearch 7.10.2 mongodb 4.0.28

  • Service logs, configurations, and environment variables:

3. What steps have you already taken to try and solve the problem?
Tried deleting and rebuilding the item. Tried adding a new Item.

4. How can the community help?
Has anyone run into this problem and do you have any tips on where to look for a fix?

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

Server reboot seems to have fixed the issue. :thinking:

Hey @gkaram && Welcome

First like to know what exactly was tried before the error occurred.
What did it show in the logs (i.e., Elasticsearch & Graylog)?

It was working and I was making edits Then it started throwing the errors. The page I was modifying would no longer let me make modifications without throwing the error. I tried closing/opening the browser, removing and adding new pages to the dashboard which also failed.

The Graylog log file showed license errors. I didn’t look a the elasticsearch log as it seemed like a graylog problem.

Server restart fixed the problem. I have multiple GL servers running at different clients without issue. This is the first I have seen this prioblem.

Hey @gkaram

What I do when something like this happens. I start looking in other log to see if there were any problem with other services and/or applications. For example I just had Graylog Server become unresponsive then i found out it was kernel error.

When dealing with Dashboard and Widgets and get a error “can’t convert undefined to object” I would have looked into Elasticsearch logs, since it Index’s log and creates fields, also would look into MongoDb since it store metadata. just an idea.

I’ll keep that in mind. Thanks for the quick response and assistance!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.