Web Interface access issues after upgrading from 2.0.2 to 2.2


(Alex Pilon90) #1

Hi there,

We’re running Graylog 2.0.2 on a VMWare environment as a Linux Virtual Appliance.

We tried updating to the latest available version yesterday evening, using the Graylog Omnibus package. The update itself went without a hitch, but post-update, we could not access the web interface anymore.

Before the update, we were using https://netlog.domain.com. We did not need to specify any ports or anything else.
After the update, https was not working anymore, and we had to specify port 9000 at the end of the URL or else it wasn’t working (http://netlog.domain.com:9000).

The person who configured the application is gone from our enterprise, so we have very little information on how the appliance is configured.

Is there a fix for this issue, and if so, how would I go about fixing this ?

I had initially posted this in the issues section of the GitHub page, was referred here as well as to the section about installing a custom SSL certificate. The certificate is already installed on the virtual appliance before the update, but doesn’t seem to be working after the update. Does it need to be reinstalled after each update ?

And also, I noticed that post-update the nginx service did not start back up. Does it need to be restarted manually post-update, or this means there are other issues ?

Thanks,


(Lennart Koopmann) #2

This sounds like nginx was used as a reverse proxy. Make sure it is running.


(Alex Pilon90) #3

I can’t seem to get it to start back up.
When I get the services status, nginx is set to “Disabled”. If I try to restart it (sudo graylog-ctl restart nginx), I get no errors but the service still does not start.
I even tried to re-enforce SSL (sudo graylog-ctl enforce-ssl and then sudo graylog-ctl reconfigure), to no avail.


(Lennart Koopmann) #4

Nothing in the nginx or syslog logs?


(Jan Doberstein) #5

@AlexPilon90

did you upgrade direct from 2.0.2 to 2.2 ?

That is something that shouldn’t be done and clear if you had looked at the Upgrade Guides.

Could you please paste the output of sudo graylog-ctl show-config

Additional you can find some help here: http://docs.graylog.org/en/2.2/pages/configuration/graylog_ctl.html