Upgrading Graylog 3.3.9-1 (OVA) to 4.0.1-1 kills the server


I tried to upgrade Graylog OVA server from version 3.3.9-1 to the new 4.0.1-1 version, following the official instructions here: https://docs.graylog.org/en/4.0/pages/installation/operating_system_packages.html#operating-package-upgrade-deb-apt

However, after the installation I can’t access the web GUI.Screenshot_3

Any idea?

Could be the same issue I was having:

Which incidentally is here in the upgrade notes:


I’m quite sure it’s not the same problem, since I can’t get to the GUI even when I’m using the IP…

It’s a very simple installation, everything default, with no HTTPS - just OVA from Graylog website updated to the latest version and then upgraded to the latest 4.0 version.

  1. Check server is running
  2. Check server is reachable using curl -v
  3. If yes - check developers console, press F12 and look at Network tab

Howdy @CatchyNick. I just spun up the ova on 3.3.9-1 and upgraded to latest. I ran into the issue that @tmacgbay mentioned, enabled cors, and was able to log in. Did you ever get any info from your browsers devtools console?

Enabling cors solved the problem:

vi /etc/graylog/server/server.conf
http_enable_cors = true

Thanks @aaronsachs

1 Like

Sure thing! Glad to know that solved it!

1 Like


testing it out is always better than taking a guess.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.