Unhelpful error on web UI, logs don't seem to show any issues

So I am seeing this image currently on the web interface: (see below)

however in the graylog server log, it is connecting fine to MDB, elasticsearch is running fine, and the server.log states the following:

2021-01-17T22:49:36.014Z INFO [JerseyService] Started REST API at <>
2021-01-17T22:49:36.015Z INFO [ServerBootstrap] Services started, startup times in ms: {OutputSetupService [RUNNING]=31, EtagService [RUNNING]=31, JobSchedulerService [RUNNING]=32, BufferSynchronizerService [RUNNING]=32, GracefulShutdownService [RUNNING]=34, InputSetupService [RUNNING]=36, KafkaJournal [RUNNING]=45, UrlWhitelistService [RUNNING]=45, JournalReader [RUNNING]=46, ConfigurationEtagService [RUNNING]=54, MongoDBProcessingStatusRecorderService [RUNNING]=60, StreamCacheService [RUNNING]=108, LookupTableService [RUNNING]=132, PeriodicalsService [RUNNING]=177, JerseyService [RUNNING]=24120}
2021-01-17T22:49:36.020Z INFO [ServiceManagerListener] Services are healthy
2021-01-17T22:49:36.023Z INFO [ServerBootstrap] Graylog server up and running.
2021-01-17T22:49:36.024Z INFO [InputSetupService] Triggering launching persisted inp

The only thing that seems to be complaining at all is this, from systemctl status:

WARNING: sun.reflect.Reflection.getCallerClass is not supported. This will impact performance.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by com.google.inject.assistedinject.FactoryProvider2$MethodHandleWrapper (file:/usr/sha
WARNING: Please consider reporting this to the maintainers of com.google.inject.assistedinject.FactoryProvider2$MethodHand
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

I am running Graylog4 having followed the Ubuntu installation instructions, also worth pointing out I have a working node on a different server running GL3 which has an almost identical conf (changed the IPs for publish and external URL etc obviously)

Would be very grateful for any assistance offered.

worth noting that uncommenting http_enable_cors in the config didn’t help (had seen someone else do that where it worked)

I can confirm that if I use the IP instead of hostname in the address bar I can log in

edit: solved, had to change the value from false to true in http_enable_cors as well as uncommenting.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.