This site can’t be reached took too long to respond

Hello,

I installed graylog 5 in june 2023.
Running with mongo v6.0.6 and elasticsearch 7.10.2 on Rocky Linux 9
It was working perfectly. Using NXLOG and I configured input with TLS.

Now, the web interface does not response at all :
“This site can’t be reached took too long to respond.”

I tried to connect on my mongoDB :

# mongosh
Current Mongosh Log ID: 6603f4eccdff0f119cdc8591
Connecting to:          mongodb://127.0.0.1:27017/?directConnection=true&serverSelectionTimeoutMS=2000&appName=mongosh+1.10.1
MongoNetworkError: connect ECONNREFUSED 127.0.0.1:27017
"

And a curl : ]# curl https://X.X.X.X:9000
curl: (7) Failed to connect to X.X.X.X port 9000: Connection refused

mongo, graylog and elasticsearch are running.
In the log, I have got this error :

2024-03-27T10:20:36.709+01:00 INFO  [MongoDBPreflightCheck] MongoDB is not available. Retry #1
2024-03-27T10:20:38.709+01:00 INFO  [cluster] Cluster description not yet available. Waiting for 30000 ms before timing out
2024-03-27T10:21:08.710+01:00 INFO  [MongoDBPreflightCheck] MongoDB is not available. Retry #2
2024-03-27T10:21:10.710+01:00 INFO  [cluster] Cluster description not yet available. Waiting for 30000 ms before timing out

AND :

2024-03-27T10:16:57.106+01:00 INFO  [VersionProbe] Elasticsearch is not available. Retry #214
2024-03-27T10:17:02.107+01:00 ERROR [VersionProbe] Unable to retrieve version from Elasticsearch node: Failed to connect to /127.0.0.1:9200. - Connection refused.
2024-03-27T10:17:02.108+01:00 INFO  [VersionProbe] Elasticsearch is not available. Retry #215
2024-03-27T10:17:07.111+01:00 ERROR [VersionProbe] Unable to retrieve version from Elasticsearch node: Failed to connect to /127.0.0.1:9200. - Connection refused.
2024-03-27T10:17:07.113+01:00 INFO  [VersionProbe] Elasticsearch is not available. Retry #216

EDIT :
I find those erros :

{"t":{"$date":"2024-03-27T12:16:55.128+01:00"},"s":"E",  "c":"NETWORK",  "id":23024,   "ctx":"initandlisten","msg":"Failed to unlink socket file","attr":{"path":"/tmp/mongodb-27017.sock","error":"Operation not permitted"}}
{"t":{"$date":"2024-03-27T12:16:55.128+01:00"},"s":"F",  "c":"ASSERT",   "id":23091,   "ctx":"initandlisten","msg":"Fatal assertion","attr":{"msgid":40486,"file":"src/mongo/transport/transport_layer_asio.cpp","line":1130}}
{"t":{"$date":"2024-03-27T12:16:55.128+01:00"},"s":"F",  "c":"ASSERT",   "id":23092,   "ctx":"initandlisten","msg":"\n\n***aborting after fassert() failure\n\n"}

Have you any ideas ? What’s happing ? I dont change any settings or config.
What can I check ?

Thanks !

Hey @Malcolm

Most probably you missed to shutdown properly your mongod previous time so there is socket file left in the tmp folder that you need to remove manually before you try to start the mongod process again:

rm /tmp/mongodb-27017.sock

Restart service

Systemctl restart mongod

Check status

systemctl status mongod

As for

Unable to retrieve version from Elasticsearch node: Failed to connect to /127.0.0.1:9200. - Connection refused.

Check the services. If there not running then check configuration again.

systemctl status  elasticsearch
systemctl status graylog-server

If the services are not running or failed to start you can use this to investigate why. This may give you a better insight on what going on.

journalctl -xeu  graylog-server

or

journalctl -xeu elasticsearch

Hi,

Thank you, the services are up.

But, I can’t reach the web interface because “took too long to respond.”
I checked in “/var/log/graylog/graylog-server” : no error, only info.

Have you any ideas ?

Regards,
Malcolm

Hey

Did you restart Graylog service?

Hi,

Yes of course. Still without warning but the web interface is not reachable :frowning:

Hey,

Is it possible to see your GL config? If so make sure personal info is removed. This looks like a configuration issue.