The timestamp returned by the graylog API is abnormal

I use the API provided by Graylog, but the timestamp of the returned data is located in UTC. The user and system time zones have also been modified to the current time zone, but there is no way to return the normal time through the API.

So how do I fix this returned exception

New users can only upload one image, so they can only upload images by replying


The time zone parameters filled in the API also cannot take effect

Heloo && welcome @lvjw

I looked over your post,not sure. Only idea I can think of when using API is that Opensearch and/or Elastic defaults to UTC.

Is the time returned accurate in UTC?

The database of es has not been changed. The default time zone may be UTC, but the API interface of Graylog has not changed the time zone

This is indeed the UTC time, but the time zone parameter in the API did not change the timestamp after use

Hi lvjw,
I tested this myself and found the same result. The time_zone parameter is ignored. IMO this is a bug (not working as designed/intended). I’ve opened an issue here: `/api/views/search/messages` does not obey `time_zone` argument, always returns UTC · Issue #15030 · Graylog2/graylog2-server · GitHub .

There is indeed this problem, and neither the user’s time zone nor the server’s time zone is used

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.