Telegraf + Graylog not working

Hi everyone

I’m trying to send Graylog data to Grafana ( ) but i’m unable to do it.

I have followed the steps about creating the token, writing graylog.conf at /etc/telegraf/telegraf.d but telegraf log keeps saying :
Response from url “blablabla:9000/api/system/metrics/multiple” has status code 400 (Bad Request), expected 200 (OK)

This is actually working : curl -u user:pass -X POST -H ‘X-Requested-By: cli’ -H ‘Accept: application/json’ -H ‘Content-Type: application/json’ -d ‘{“metrics”:[“jvm.threads.count”]}’ ‘blablabla:9000/api/system/metrics/multiple?pretty=true’

This is the content of my graylog.conf

servers = [“http://blablabla:9000/api/system/metrics/multiple”]
metrics = [“jvm.threads.count”]
password = “token”
insecure_skip_verify = true

I’ve tried with token configuration and with username / password configuration, Nothing works. ( I have reduce my config to the minimum )

Hope you can help me with this…


he @maxorca

what Graylog version and what telegraf version did you use?

Hi @jan

Graylog 3.2.3+a9c061c, codename Ethereal Elk
Telegraf v1.7.2 (git: release-1.7 c6feb056)

Any suggestion?
Any test that we can make this works?

We use this dashboard here as well.
When using the graylog.conf file, it didn’t work. In the telegraf.conf there is an input defined for Graylog. Use your settings from the graylog.conf file and put them in the telegraf.conf file.

Hope I could help.

HI @shenke, thanks for replying.
I’ve tried that configuration and still doesn’t work
Same error from telegraf log
2020-04-15T07:20:20Z E! Error in plugin [inputs.graylog]: Response from url “http://XXXXX:9000/api/system/metrics/multiple” has status code 400 (Bad Request), expected 200 (OK)


Have you deleted the graylog.conf file?
Do you see any message in the GL log files? Sometimes it’s a little bit too chatty, but helpful.
Have you had a look on the Telegraf Github page?
Maybe there is already an issue open for that, you could open an issue, if there is none.

EDIT: Found this issue:
Your Telegraf version (1.7.2?) could be too old for Graylog. Please try at least 1.9.x, version 1.14.1 is the latest version.

1 Like

That’s it @shenke

I have updated telegraf to last version and everything is working!!

Thanks a lot for your help!! :star_struck:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.