SSO config page missing

Hi,

With reference to https://docs.graylog.org/en/3.1/pages/installation/docker.html, I’ve built a Graylog container with SSO but the SSO config page doesn’t seem to show up. Can someone please help?
Steps taken:

  1. Compose the Dockerfile as followed and built the container:

FROM graylog/graylog:3.1
RUN \
curl -o /usr/share/graylog/plugin/graylog-plugin-auth-sso-3.0.0.jar https://github.com/Graylog2/graylog-plugin-auth-sso/releases/download/3.0.0/graylog-plugin-auth-sso-3.0.0.jar

  1. Run docker-compose stop and docker-compose start.

  2. Clicked in System/Authentication on the dashboard.

Result:
No reference of SSO on the left.

BTW, I’m using the docker-compose file given in docker.html (the version with persistence) and I’ve also tried deleting the volumes.

The jar files in the plugin dir:

docker exec -it graylog_graylog_1 bash graylog@86c2e7568553:~ ls -la /usr/share/graylog/plugin/
total 29480
drwxrwxr-x 1 graylog graylog 4096 Jan 23 00:44 .
drwxr-xr-x 1 graylog graylog 4096 Jan 14 15:39 …
-rw-r–r-- 1 graylog graylog 623 Jan 23 00:44 graylog-plugin-auth-sso-3.0.0.jar
-rw-rw-r-- 1 graylog graylog 21198864 Jan 14 15:10 graylog-plugin-aws-3.1.4.jar
-rw-rw-r-- 1 graylog graylog 3729962 Jan 14 15:09 graylog-plugin-collector-3.1.4.jar
-rw-rw-r-- 1 graylog graylog 5239694 Jan 14 15:10 graylog-plugin-threatintel-3.1.4.jar

he @skwokie

I just tried the manual download and that is working. The size you shown in the ls is wrong and something might not have worked with the download. When you want to build your own setup you need to create your own image the docker-compose is using the provided image and does not include the build command.

My personal advice - use the bind-mount to include the plugin and do not build you own image.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.