Server Always Starts with Graylog service running, Elasticsearch status: dead

1. Describe your incident:

So each time my Graylog-Server reboots, I need to manually go in , stop Graylog and Elasticsearch (I know they should be co-located), then start Elastic, wait for it to initialize, and lastly start Graylog.

4. How can the community help?

Has anyone had success in changing the Boot Order so that Graylog wont start until Elasticsearch is up?

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]


Not sure why Graylog server needs rebooting that much, but you can run the sleep command before your ExecStart with ExecStartPre :

ExecStartPre=/bin/sleep 30

This also could correspond with TimeoutSec as shown below


You can disable startup on GL service.

systemctl disable graylog-server

Then manually start Graylog service up after Elasticsearch is fully started.

To change the boot order, prioritize a different OS or kernel configuration edit the file /etc/default/grub

To be honest, I can randomly reboot my single node Graylog server and no issue will occur. Not sure why this environment is having issues.

Hope that helps

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.