Reports not saving selected widgets or not able to choose different widgets

  1. Describe your incident:
    Using Graylog enterprise to generate reports, I create a report and can see all the widgets listed.
    No matter which widgets I select for the report, it unselects the ones i’ve chosen and it selects the same first two each time I click the green Update Report button

Looking at the screenshot below, I have everything unselected, I then select the 3 Mail-Server and click update report, then when I go back into the report its as per the photo and its chosen what it wants.

Please advise as this testing stops us testing to then purchase to use the product in a production environment.

  1. Describe your environment:
    Ubuntu 20.04.3 LTS
  • Package Version:
    Graylog 4.2.1+5442e44 on (Ubuntu 11.0.11 on Linux 5.4.0-90-generic)

I have since found how to rename each widget in the dashboard so they are all named correctly in the report setup page, but still with same error.

Can’t select all of just one section (ie mail server) it will unselect some and auto select some of the first dashboard

Hello && Welcome

We would need more information on this error your seeing.

When you refer to “it will unselect some” are you talking about Graylog is doing this?

The best way to help us, help you is to show the logs from the same time as your creating this report. Maybe there is something in there that may help. Any direction is better then no direction. All my widgets are named differently/simpler. Not sure if that would be the issue. For a better understanding have a look at this post.

The following screenshots is what happens.

Screenshot shows nothing selected, before I make selection.

Selecting all under Mail Server failed logins & clicking green update report button.

When I go back in to check the report, Graylog has made the following changes its self.

Hello,

Is this something similar to what your experiencing?

Did you see anything that may pertain to this issue in your log files? Preferably Graylog or Elasticsearch?

Unfortunately, I cant reproduce this in my lab. Have you tried posting here.

Hello,
I don’t think so and I’ve only recently started using Graylog so am unable to roll back to an older version like they explain.

My problem with Graylog is what I explained on the Nov 29th with my three photos, Graylog is not saving the report sources I’ve selected.

Hello

I understand

So did you check out your log files as suggested above? It might have some information that could help resolve your issue.

If your unsure where the logs files are located here is documentation for that below.

https://docs.graylog.org/v1/docs/file-locations

The pictures are great to show but without more information I’m not sure. It could be the way you install Graylog , configuration, permissions, etc… Sorry for not being clear, I didn’t want you to roll back to a different version I want you to see if it pertained to your issue. Like I said I cant reproduce this.

Yes I see, hence why I suggested it being a bug and gave you this link.

Graylog --Bug report / change request

Anything else you can show use, to help you would be great.

Hope that helps