RabbitMQ - Can't Bind To Exchange - Not Found


(Chris Platts) #1

Hi,

I’ve just come back to set up Graylog after having played with it a while back. I had successfully got it pulling messages via a GELF-over-AMQP input from RabbitMQ.

I’m now trying to set it up again, but for some reason Graylog’s getting an error when attempting to start the input:

channel error; protocol method: #method<channel.close>(reply-code=404, reply-text=NOT_FOUND - no exchange 'graylog.messages' in vhost '/', class-id=50, method-id=20)

The thing is, the exchange graylog.messages does indeed exist. It’s set as a durable fanout exchange and not to auto-delete.

It’s clearly connecting to Rabbit OK since it’s able to display the error. I’ve tried with Rabbit 3.6 and 3.7 as well as the past couple of revisions of Graylog.

I’m at a bit of a loss as to what’s going on. I’ve quadruple-checked the configuration, but am still stuck.

Any help greatly appreciated!

[EDIT] If I turn off Bind to Exchange the input starts successfully. However, I need it to bind, so the problem remains. Also, this is a ‘clean’ install of both Rabbit and Graylog. All work is done with Rabbit’s default vhost and default credentials.

Thanks,
Chris


(Jan Doberstein) #2

When I use Logstash to push messages into Graylog (via AMQP) the configuration looks like:

output {
        rabbitmq {
                exchange => "log-message"
                exchange_type => "fanout"
                key => "log-message"
                host => "AMQP_HOST_NAME"
                vhost => "graylog"
                ssl => true
                workers => 1
                durable => true
                persistent => true
                port => 5671
                user => "USERNAME"
                password => "PASSWORD"
                }
        }

The above is basically what is written in the guide: https://github.com/Graylog2/graylog-guide-syslog-amqp

The connection from Graylog is only successfully possible once the first worker pushes data into the exchange. The reason why I had forgotten, so I’m not able to explain - but AFAIK that has something todo with the way AMQP is working.


(system) #3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.