Problems with the :12900 api access


(John Reyes) #1

Hey There

i’m having some problems with my config.

when i set the rest_api to the external ip (and i have nat the port 12900, i can access the web interface, but not start my udp syslog.

if i set it to the internal ip:12900 the weblogin just stalls af loading…
if i access it here from the same subnet, everything works fine.

how to i configure it to work behind a nat?


(Jochen) #2

Try using the following configuration:

rest_listen_uri = http://0.0.0.0:9000/api
web_listen_uri = http://0.0.0.0:9000/api
web_endpoint_uri = http://<Public IP address or host name>:9000/api

# This setting only if you have a single Graylog node and not a cluster
rest_transport_uri = http://127.0.0.1:9000/api

(John Reyes) #3

but my rest api port has been 12900?


(Jochen) #4

Then change the settings accordingly, if you want to…


(John Reyes) #5
rest_listen_uri = http://<LAN address>:12900
web_listen_uri = http://0.0.0.0:9000
web_endpoint_uri = http://<Public address>:12900
rest_transport_uri = http://<LAN address>:12900

did the trick :slight_smile:
thanks for the help!


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.