Output Stream is not able to send logs to Syslog


I have all the streams setup and log messages are showing (local input is just one on UDP 1514)
I created an output and assigned it to each Stream but the receiver Syslog is not able to see any logs.
Please suggest what else to check.

  • format:
  • host:
  • keystore:
  • keystorePassword:
  • maxlen:
  • port:
  • protocol:
  • transparentFormatRemoveHeader:
  • truststore:
  • truststorePassword:
  • utf8:

Syslog is usually used via UDP, perhaps you should try changing TCP to UDP in the output’s configuration ?

If that does not solve your problem, please check if the receiver Syslog is really listening on TCP/514 by using telnet from Graylog.

Otherwise how did you install the Syslog output on Graylog ? Did you download a plugin from the Marketplace ?

Yes, the UDP and TCP ports 514 are open and I can do nc to syslog.
I only got a reply from them that they are not able to receive logs. I did check in our firewall (graylog is behind local firewall) and there are no messages being sent but when I test via nc, it works…
so there is no network issue.

the plugin is downloaded from marketplace “graylog-output-syslog-4.2.6.jar”
I also selected the output in each stream. tried changing port to UDP but still no activity on local firewall…

I resolved it with server reboot and re-assigning output to each stream

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.