NxLog on Linux is failing

Dear Graylog community,

I have an issue with NxLog and Graylog Sidecar. I have a few Debian 10 & 11 server.

I installed NxLog CE using the deb package, and desactivated nxlog service at startup. I’ve also installed the graylog Sidecar using the Graylog documentation.

All the Graylog Sidecars are showing up on the Web interface. I have configured NxLog and deployed the configuration through the sidecar menu.

It runs very well “out of the box” on Debian 10, but on Debian 11 it’s another story.

I have the following error on ALL deb 11 :

ERROR failed to open /var/log/auth.log;Permission denied

I unsuccessfully tried to add NxLog user to group adm which can read the log files, but it’s not working.

Has anyone noticed this issue with Deb 11 ?

Thanks for your answers,

Best regards


I found the answer by myself.

I uninstalled nxlog, reinstalled nxlog and added the nxlog user in adm group BEFORE applying the configuration in Graylog.

Now it works flawlessly ! :smiley:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.