No Longer Able to Access API after update to 4.05


Elasticsearch: 6.8
Graylog: 4.05
MongoDB: 4.02

After updating everything appears to run properly and I’m receiving data in Graylog but any attempts to share Streams or load Dash boards result in 500 errors regarding accessing the API. The API URL being shown is incorrect but I’m unsure how to configure it so that it is correct.

Previously my Graylog instance was accessible via:

Old server.conf:
rest_listen_uri =
web_listen_uri =
web_endpoint_uri =

New server.conf:
http_bind_address =
http_external_uri =

All other settings remain default or the same but I receive errors for trying to reach the API at and even when I try to access it directly via I get {“type”:“ApiError”,“message”:“IOException encountered while reading from a byte array input stream”}. I’m unsure what setting or configuration has changed that I’m no longer able to access this. Any assistance would be appreciated.

I was able to solve my own issue. For anyone else who comes across this issue it turned the issue had nothing to do with the API itself and with some value in the views collection in Mongo. Apparently there was some value for a unit in there that it just wasn’t able to parse. After looking and being unable to figure out what that value was I just deleted all values in the views in Documents and I’m able to share streams again. Still unclear how a weird value in Views kept me from sharing streams and the loss of all the Dashboards is a bit of an inconvenience but I’m just glad the functionality is back.

Was there a particular command you ended up running to clean up the views?

I just removed all documents from the views collection in Robo 3T but I suppose any command that also achieved the same would’ve worked.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.