Lucene version mismatch - opensearch install v2.5.0 has lucene mismatch

installed opensearch 2.5.0 before graylog and it does not start

in thread “main” java.lang.AssertionError: Lucene version mismatch this version of OpenSearch requires lucene version [9.1.0] but the current lucene version is [9.4.2]
opensearch[3750]: [2023-04-20T18:43:38,642][WARN ][stderr ] [system-name] #011at org.opensearch.bootstrap.Bootstrap.checkLucene(

1. Describe your incident:
installed mongo - no problems it is running
next Ubuntu 2

2. Describe your environment:

  • OS Information:Ubuntu 20.4

  • Package Version: eventually graylog 5.0 open

  • Service logs, configurations, and environment variables:
    So it looks like opensearch2.5 or opensearch 2.6 (lucene 9.5.0) have a mismatch with lucene
    I tried installing opensearch with apt .
    I did not see anywhere that I could not install opensearch2.5 or higher??

3. What steps have you already taken to try and solve the problem?
I am in process of installing opensearch 2.0.1 with a tarball

4. How can the community help?

Helpful Posting Tips: Tips for Posting Questions that Get Answers [Hold down CTRL and link on link to open tips documents in a separate tab]

Hey @fixvirus

How did you install Opensearch-2.5.0?

You may need to clean up your repo and/or remove version 2.6.


Im running Opensearch on Ubuntu 22.0.4 I had to use this documentation.

I did not use opensearch’ .deb or tar files - I used apt install opensearch and it installed v2.6.0 — So I can use the actual .deb from opensearch.or

Also I did a apt purge to remove opensearch 2.6.0
apt purge opensearch=2.6.0
Trying now…

Ok after an install with the .deb file as in

sudo dpkg -i opensearch-2.5.0-linux-x64.deb

Now opensearch runs at port 9200
even though the lucene version is 9.4.2

“cluster_name” : “graylog”,

“version” : {
“distribution” : “opensearch”,
“number” : “2.5.0”,
“build_type” : “deb”,
“build_hash” : “b8a8b6c4d7fc7a7e32eb2cb68ecad8057a4636ad”,
“build_date” : “2023-01-18T23:48:43.426713304Z”,
“build_snapshot” : false,
“lucene_version” : “9.4.2”,
“minimum_wire_compatibility_version” : “7.10.0”,
“minimum_index_compatibility_version” : “7.0.0”
“tagline” : “The OpenSearch Project:

Trying to configure Graylog now


Thats good, Im not sure but did you install MongoDb already?

Yes did not mention, since it worked.
Mongodb was good.
I will review all my configuration soon.
Hopefully it will run soon, then i can work on ingest etc.

1 Like

:smiley: The graylog environment seems to work.
Now need to work on ingesting messages and more figure out what to keep and more in that vein.
So looking back at this issue…

  1. For some reason the install from Ubuntu to install opensearch (which installed 2.6.0 first) went awry .
    even downgrading to 2.5.0 did not work.
  2. only after gsmith suggested to install from downloads (like .deb ubuntu/ debian for me)
    That made opensearch work.
  3. Then I had to fix the graylog config files before everything worked. thanks for the help
1 Like

Glad I was able to help @fixvirus

awesome-yes-will-ferrell (1)

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.