ERROR: Unsupported search version: Elasticsearch:6.0.0

I am trying to complete a new install of Graylog 5.0 and I am getting the error even though I am using opensearch version 2.5.

ERROR: Unsupported search version: Elasticsearch:6.0.0

Output of curl -XGET http://admin:admin@localhost:9200:

Version 6.8.15```

I'm running Ubuntu 18.04 if that matters.

Greetings! Graylog 5 has bumped up the minimum elasticsearch version to 7.10. See Installing Graylog .

There is also a versions matrix on this page that may be helpful: Prerequisites .

You should be able to upgrade elasticsearch, but be sure not to upgrade past 7.10.2.

If possible, it is preferable to install and use OpenSearch instead as Elaticsearch 7.10 is end of life as of May 2022.

Thanks for the reply. I left put an important detail. I installed opensearch 2.5 so I’m confused with it is showing elastic at all. I ran ‘sudo apt remove elasticsearch’ and it says it’s already removed. As far as I can tell, Elastic is gone and I’m only running opensearch 2.5 but that’s the version I see when I run the curl command on port 9200

What do you get when you run curl localhost:9200 on the server where opensearch is installed?

Also what do you get when you run systemctl status opensearch and systemctl status elasticsearch


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.