Loading component failed: Loading chunk

Hello. I had created a graylog cluster for the testing purposes in the Kubernetes cluster via helm chart, but after one week I noticed that sometimes Graylog has some problems with (i thought) mongodb connection.
This task is almost the same as


In logs i can see

 INFO    [cluster] - Exception in monitor thread while connecting to server mongodb-mongodb-replicaset-2.mongodb-mongodb-replicaset.graylog.svc.cluster.local:27017 - {}
com.mongodb.MongoSocketOpenException: Exception opening socket
	at com.mongodb.connection.SocketStream.open(SocketStream.java:62) ~[graylog.jar:?]

I read , that it can be connected with Java options (something connected with dns)
Thank you for your help.

also i tried with external mongodb database, and i have the same result.

I’ve downscaled numbers of node to 1 node, and it works without any problems. I think this problem is connected with Nginx ingress controller. Maybe we have to use some ingress options like ‘stickiness’.

```
sessionAffinity: ClientIP
sessionAffinityConfig:
  clientIP:
    timeoutSeconds: 10000

I added this into the web-graylog service config and it resolved my problems. But I don’t know how it worked without this flag.

You might get better/more help with the helm chart in that community? I do not know how many of the users here use that helm chart and work with that.

I would be glad to help, but i was surprised that nobody faced with this problem , and i assumed that it helped only me. Of course i will try to help with helm chart on Saturday.

@dzirg44

I guess that they did not share their findings if they run into the same issues…

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.