JOIN GRAYLOG FOR OUR

ANNUAL CONFERENCE

Thursday,
October 21, 2021
10am-5pm CT
REGISTER NOW

javax.mail.internet.AddressException: Missing final '@domain' in string

Hi
I have set email configuration as below:

Email transport

transport_email_enabled = true
transport_email_hostname = nnn.xx.pp.com
transport_email_port = 25
transport_email_use_auth = true
transport_email_auth_username = username
transport_email_auth_password = pass
transport_email_subject_prefix = [graylog]
transport_email_from_email = graylog@pp.com

but, when i want to test it , i get error:
Error: Notification has email recipients and is triggered, but sending emails failed. javax.mail.internet.AddressException: Missing final ‘@domain’ in string ``nnn.xx.pp.com’’

How can I fix: javax.mail.internet.AddressException: Missing final ‘@domain’ in string

Note: I have use it this configuration for lots Outgoing Mail Server Settings and they send email notification as well. but i dont know why graylog returns the error.

Random guess - your transport_email_auth_username may need to be in e-mail address format?

You use unsecure communication, so check the process with TCPdump.
And if you use it over the internet change it to a secure one.

Hi ,

the error is " sending emails failed. javax.mail.internet.AddressException: Missing final ‘@domain’ in string ``"
it seems since my email hostname is without “@” , I got the error.

Hi,

unfortunately, not working

Yes, but if you check the communication, you can get closer to the problem.
I think it can caused by the remote server, or the local program/process.
If you get it, you can exclude one of it…

Hi ,

Unfortunately, in TCP dump there is no clue about SMTP or IP of mail-server
I run TCPdumt for 3mins, and try sending email from Notification panel 5 times.

in this case, you shoud find the problem in the application.
Check your recipient address.

I have set similar configuration at other services and they work,
I don’t know why graylog could accept the string: nnn.xx.pp.com
It does not include any @…
maybe, default Host0Name should be something like: nnn.xx@pp.com
How can I fix “javax.mail.internet.AddressException” setups?

check the recipients in the alerts setting. maybe there are the problem.

how can I find “org.apache.commons.mail.EmailException” module .
Where is it used/call?

hi

sender should be like: graylog@domail.com , at web api setup
no change done on server mail configuration.
good luck

also
set : ransport_email_use_auth = false on config file., even though you set user name and password to authentication.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.