Java supported version


#1

Hello,

I saw similar topics but all was about quite old version of Graylog.

We plan new installation of Graylog (we also plan install Elasticsearch on the same machine).

Few days ago Elastic released Elasticsearch 6.6 which supports Java 11.
In Graylog documentation I can see latest supported version is Java 8 (I suspect documentation was writed where elastic also support only java 8) .
On Oracle webpage is information

Java SE 8 is going through the End of Public Updates process (…) until at least the end of December 2020 for Personal Users, and January 2019 for Commercial Users

Because it is new installation we thing about install newest components.

Could you tell me what is last officially supported (by Graylog 2.5) version of Java?


(Kornflex) #2

Hi,

Graylog doesn’t support ES 6.x
I’m not sure but it’s mabe the reason why.

http://docs.graylog.org/en/2.5/pages/installation.html#system-requirements


(Jan Doberstein) #3

@gorek the documentation is still valid - currently Java 8 for Graylog
@kornflex you are wrong - since 2.5 Graylog supports ES 6


#4

Yes, but the documentation inconsistent :slight_smile:
“Graylog prior to 2.5 does not work with Elasticsearch 6.x!”


(Jan Doberstein) #5

read the complete sentence - that is rephrased:

Since Graylog 2.5 Elasticsearch 6 is support. Earlier versions do not work with Elasticsearch 6.


(Kornflex) #6

Oups, sorry :slight_smile:

I need to learn more english :slight_smile:

I will try an update so


#7

Is any difference between Oracle JDK and Open JDK?
Which one in better choice?


(Jan Doberstein) #8

please check http://bfy.tw/MBBe


#9

Oh… sorry my grandpa told me I can use Google but I’m not tried yet :wink:
OK. More seriously I’m asking in context of Graylog new installation.

So am I understand I can choose any of them.


(system) closed #10

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.