Issues with secret password and sha2 password

Hello,

I am trying to set up a graylog server but I have issues with these two passwords:

I am running an ubuntu vm with the newest versions of graylog, mongoDB and opensearch.

Also the web-console looks weird to me.

The 4. screenshot contains the commands I used.

Thanks!

Hey @Domi.2109

Have you seen this documentation here

If not, try that see if it works.

Hi @gsmith

Everything was installed as described in the manual.

Hey @Domi.2109

what I did was…

This is for password_secret.

 < /dev/urandom tr -dc A-Z-a-z-0-9 | head -c${1:-96};echo;
ocFlg3phZ9lOMW6MKSioardY7xXd6Yz9WVrr6HBmynZivOVgrrsUe3hfFlNUSGO5xUUYRf8Foja58dRf-8PVsCtC6hkhYf0e
 password_secret =  ocFlg3phZ9lOMW6MKSioardY7xXd6Yz9WVrr6HBmynZivOVgrrsUe3hfFlNUSGO5xUUYRf8Foja58dRf-8PVsCtC6hkhYf0e

Then for root_password_sha2

 echo -n "Enter Password: " && head -1 </dev/stdin | tr -d '\n' | sha256sum | cut -d" " -f1

Enter Password: password123

ef92b778bafe771e89245b89ecbc08a44a4e166c06659911881f383d4473e94f

Results:

root_password_sha2 = ef92b778bafe771e89245b89ecbc08a44a4e166c06659911881f383d4473e94f

Its not clear what you issue is.

Hey @gsmith,

I could figure it out. The Problem was that i did not configure the elasticsearch parameter in the server.conf. Unfortunatly this was not documented and I wonder why this parameter exists, because you have to use opensearch.

1 Like

Hi Domi, can you clarify what this means? As far as I can find, this parameter is documented via our docs site and specifically for the installation. Let us know if you have feedback on what we can improve.