HTTP GELF input and HTTP Keep-Alive


I installed a graylog server and I use a GELF HTTP input behind an HAProxy instance.
I noticed that a lot of message are dropped as soon as I use the HTTP-Keep-Alive.
As soon I disable that, 100% of my messages are ingested.

  • OS Information:
    Debian 11

  • Package Version:
    graylog-server 5.1.3-1

I tried to sent my messages directly to the graylog server, same result.

Thanks for your help.

Are you seeing any errors in your graylog server log? (typically /var/log/graylog-server/server.log)

edit: i did some quick testing, but unfortunately wasn’t able to replicate any issues using the GELF HTTP input and the ‘TCP keepalive’ checkbox.

I have the same issue. graylog community, custom python client. If I enable keepalive in requests (using the session object) only the first message works. Using individual connections in the client works.

no errors in log


can you share your code or an except that i can run to reproduce?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.