How filter exacle day


(Leonardo Ortiz) #1

Hello.
I wan’t a filter that show “today” access, it means 00:00hs to now time of the day.
Tried several keywords but it always bug when 21:00hs arrives…
Maybe is a bug with timezone or natty? Im on -03:00 UTC.

Keyword that i tried:
today midnight -0300 to tomorrow midnight -0259
Works fine but when we are in >21:00hs shows:
Preview:2018-05-29 00:00:00 to 2018-05-29 23:59:00

today midnight -0300 UTC to tomorrow -0300 UTC
Same as bellow.

yesterday midnight -0300
No.

Today midnight t now
Wrong.


(Pedro Miguel Pereira Serrano Martins) #2

Hello,

I believe that what you need is a filter with an absolute time frame selector:

http://docs.graylog.org/en/2.4/pages/queries.html#absolute-time-frame-selector

This should give you what you need.

As for setting the correct timezone for your account, you admin needs to go to: System -> Authentication -> select user, and then select the timezone for that user.

If you are the admin, then you need to change the server.conf:

http://docs.graylog.org/en/2.4/pages/configuration/file_location.html#default-file-location

And change the field root_timezone to the correct timezone.

Hope it helps.


(Leonardo Ortiz) #3

Hello.

Relative filter with “1 day”, filter 1 day before current time, so now (22:05) will filter from 22:05 of yesterday to 22:05 now… I want filter current day, starting from 00:00 to current time.

My timezone is OK, the filter works fine, but when we are in 21:00hs the filter just bugs…
Look the attachment please.

GLGL2


(Pedro Miguel Pereira Serrano Martins) #4

Instead of using the natural language filter, have you tried with the absolute filter or using the relative filter with the default options ( Search in the last X minutes ) ?

Does the error also happens when you do it this way?


(system) #5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.