Graylog web interface


(Can) #1

Checked here

yet I had a similiar problem. My nodes were new with not selinux no, iptables and no firewalld or any other software was installed.
I realized after restarting server 2-3 times it worked. Hope thats so simple workaround because when its in production its not nice to restart it everytime especially when more than 1 can fail at the same time. Since I needed to restart the whole service (even if there is another way didnot know it) if I need to restart the whole cluster than I loose messages in the meanwhile.


(Philipp Ruland) #2

Hey @CanBuyukburc,

can you please elaborate a bit more? Your log files when (re)starting the graylog services or the output of

$ curl -i http://<yourIP>:9000/
$ curl -i -H 'Accept: application/json' http://<yourIP>:12900/

would help identifying your problem :slight_smile:

Also your configuration of graylog would be helpful, the error is often inside the detail :slight_smile:

Greetings - Phil


(Can) #3

curl -i http://:9000/

HTTP/1.1 200 OK

X-UA-Compatible: IE=edge
X-Graylog-Node-ID: 858e6fe1-c997-4f6a-b3c7-c8e507f705b4
Content-Type: text/html
Date: Tue, 25 Jul 2017 06:36:01 GMT
Content-Length: 1290

Graylog Web Interface
<script src="/assets/polyfill.35e28e4da7743596569a.js"></script>

<script src="/assets/plugin/org.graylog.plugins.pipelineprocessor.ProcessorPlugin/plugin.org.graylog.plugins.pipelineprocessor.PipelineProcessorPlugin.0cbe11128085ed745b77.js"></script>

<script src="/assets/plugin/org.graylog.plugins.map.MapWidgetPlugin/plugin.org.graylog.plugins.map.MapWidgetPlugin.5011f2ebff35ef956f1b.js"></script>

<script src="/assets/plugin/org.graylog.plugins.enterprise_integration.EnterpriseIntegrationPlugin/plugin.org.graylog.plugins.enterprise_integration.EnterpriseIntegrationPlugin.3e5ff59c400f972516bd.js"></script>

<script src="/assets/plugin/org.graylog.plugins.collector.CollectorPlugin/plugin.org.graylog.plugins.collector.CollectorPlugin.13edb0af11e27a17b001.js"></script>

<script src="/assets/app.35e28e4da7743596569a.js"></script>

Had same outcome.
The conf file is too long is there any specific setting you are looking for ?


(system) #4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.