Graylog unable to collect data from Filebeat

Hello Everyone,

I have installed graylog 4.0 on server-1 and it running successfully. On the other hand, on server-2, I have a website deployed behind an nginx webserver. I want to collect all the logs of this website and send it to graylog on server-1.

  • For this I have installed Filebeat on server-2.
  • Made to changes to filebeat.yml - enabled logs and added ip of graylog(server-1)

Graylog is still not able to collect the logs.

Is there something wrong with my approach or might be a firewall issue?

Hi there,

Can you give us a bit more information? Most useful in this case would be:

  • Your Graylog server’s Input configuration
  • Your filebeat.yml

That should help us get a bit closer to finding out what the issue is.

Sure. PFB the details -

Global Input ss of graylog server -

UFW status for graylog server -


I actually solved it.

The path was not correct in the filebeat inputs section.

Thanks! :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.