Graylog HTTP load balancing using netscaler


(Esarakaitis) #1

Having issues load balancing incoming http requests from graylog.domain.com to:
graylognode1.domain.com:9000
graylognode2.domain.com:9000

my server.conf

# Web interface listen URI.
# Configuring a path for the URI here effectively prefixes all URIs in the web interface. This is a replacement
# for the application.context configuration parameter in pre-2.0 versions of the Graylog web interface.
web_listen_uri = http://graylognode1.domain.com:9000/

# Web interface endpoint URI. This setting can be overriden on a per-request basis with the X-Graylog-Server-URL header.
# Default: $rest_transport_uri
web_endpoint_uri = http://graylog.domain.com:9000/api/

this configuration works fine under HA proxy however.

Here is the config from the NetScaler:
add lb vserver GRAYLOG SYSLOGUDP -persistenceType NONE -lbMethod AUDITLOGHASH -backupLBMethod LEASTCONNECTION -cltTimeout 120
add lb vserver GRAYLOG2 UDP 172.16.104.100 514 -persistenceType NONE -cltTimeout 120
add lb vserver GRAYLOG_WEB HTTP 172.16.104.100 80 -persistenceType NONE -cltTimeout 180
add audit syslogAction GRAYLOG -lbVserverName GRAYLOG -logLevel ALL
add audit syslogPolicy “GRAYLOG POLICY” true GRAYLOG
bind lb vserver GRAYLOG2 nor1emslog02 -weight 100
bind lb vserver GRAYLOG2 nor1emslog01
bind lb vserver GRAYLOG_WEB nor1emslog01_WEB
bind lb vserver GRAYLOG_WEB nor1emslog02_WEB -weight 99
add lb monitor GRAYLOG HTTP-ECV -send “GET /api/system/lbstatus” -recv ALIVE -LRTM DISABLED -destPort 9000
bind service nor1emslog01 -monitorName GRAYLOG
bind service nor1emslog02 -monitorName GRAYLOG
bind audit syslogGlobal -policyName “GRAYLOG POLICY” -priority 100


(Jochen) #2

Please elaborate on the issue you have. It’s not clear from just the configuration snippets you’ve posted.


(Esarakaitis) #3

when you go to http://graylog.domain.com you don’t get traffic passing through


(Jochen) #4

What does that mean exactly?

Which component in your setup is blocking network traffic and how did you test it?


(Esarakaitis) #5

This has been fixed, it was a net scaler configuration issue


(system) #6

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.