Graylog (docker) + Apache2 Reverse Proxy -> Blank page

Hello,

using the default docker-compose template from http://docs.graylog.org/en/3.0/pages/installation/docker.html and the Apache2 HTTPS Reverse Proxy configuration from http://docs.graylog.org/en/2.4/pages/configuration/web_interface.html and I get a blank page with “Graylog Web Interface”. Already tried different parameters for URI_ENDPOINT and so on.

version: '2'
services:
  # MongoDB: https://hub.docker.com/_/mongo/
  mongodb:
    image: mongo:3
  # Elasticsearch: https://www.elastic.co/guide/en/elasticsearch/reference/6.6/docker.html
  elasticsearch:
    image: docker.elastic.co/elasticsearch/elasticsearch-oss:6.6.1
    environment:
      - http.host=0.0.0.0
      - transport.host=localhost
      - network.host=0.0.0.0
      - "ES_JAVA_OPTS=-Xms512m -Xmx512m"
    ulimits:
      memlock:
        soft: -1
        hard: -1
    mem_limit: 1g
  # Graylog: https://hub.docker.com/r/graylog/graylog/
  graylog:
    image: graylog/graylog:3.0
    environment:
      # CHANGE ME (must be at least 16 characters)!
      - GRAYLOG_PASSWORD_SECRET=asdfsdaf23123asdasd65
      # Password: admin
      - GRAYLOG_ROOT_PASSWORD_SHA2=8c6976e5b5410415bde908bd4dee15dfb167a9c873fc4bb8a81f6f2ab448a918
      - GRAYLOG_HTTP_EXTERNAL_URI=http://127.0.0.1:9000/
    links:
      - mongodb:mongo
      - elasticsearch
    depends_on:
      - mongodb
      - elasticsearch
    ports:
      # Graylog web interface and REST API
      - 9000:9000
      # Syslog TCP
      - 1514:1514
      # Syslog UDP
      - 1514:1514/udp
      # GELF TCP
      - 12201:12201
      # GELF UDP
      - 12201:12201/udp
        ServerName graylog.example.org
        ProxyRequests Off

        SSLEngine on
        SSLCertificateFile    /etc/letsencrypt/live/graylog.example.org/fullchain.pem
        SSLCertificateKeyFile /etc/letsencrypt/live/graylog.example.org/privkey.pem
        Include    /etc/letsencrypt/options-ssl-apache.conf

        <Proxy *>
                Order deny,allow
                Allow from all
        </Proxy>

        <Location />
                RequestHeader set X-Graylog-Server-URL "https://graylog.example.org/api/"
                ProxyPass http://127.0.0.1:9000/
                ProxyPassReverse http://127.0.0.1:9000/
        </Location>

Not sure what is wrong. Atleast I get a blank page and no connection error.

Greetings

1 Like

Changed

RequestHeader set X-Graylog-Server-URL "https://graylog.example.org/api/"

to

RequestHeader set X-Graylog-Server-URL "https://graylog.example.org/"

and

      - GRAYLOG_HTTP_EXTERNAL_URI=http://127.0.0.1:9000/

to

      - GRAYLOG_HTTP_EXTERNAL_URI=https://graylog.example.org/

fixed it for me.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.